去掉PVE订阅提示以及升级到最新

去掉PVE订阅提示

支持版本 5.1-5.2

1
2
3
cp /usr/share/javascript/proxmox-widget-toolkit/proxmoxlib.js /usr/share/javascript/proxmox-widget-toolkit/proxmoxlib.js.bak

sed -i "s#data.status !== 'Active'#false#g" /usr/share/javascript/proxmox-widget-toolkit/proxmoxlib.js

PVE升级到最新

  1. ssh连接 PVE

  2. 更换 /etc/apt/sources.list内容为

    1
    2
    3
    4
    5
    6
    deb http://ftp.debian.org/debian stretch main contrib
    # PVE pve-no-subscription repository provided by proxmox.com,
    # NOT recommended for production use
    deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
    # security updates
    deb http://security.debian.org stretch/updates main contrib
  3. 移除pve企业订阅源

    1
    rm /etc/apt/sources.list.d/pve-enterprise.list
  4. 更新

    1
    2
    apt update
    apt dist-upgrade
0%